A pony is granted: profile URLs featuring usernames April 10, 2001 11:55 AM   Subscribe

Just a thought: I'd eventually like to be able to get to user profiles via username somehow.
posted by cCranium to Feature Requests at 11:55 AM (9 comments total)

Was meinst du? Do you mean a list of user profiles?
posted by hijinx at 1:04 PM on April 10, 2001

No, I mean either via the querystring (ie, "http://www.metafilter.com/user.mefi/cCranium") or by typing something into a text box, and having a result set of users that match my something.

Basically, I want to get to user profile pages without having to know the UserId, and without having to wade through posts hoping that whomever it is I'm looking for has posted recently.

Actually, it doesn't even have to be a wildcard search. Do an exact text match (well, Upper(@foo) = Upper(UserName) type thing).

Note that I've just realised that the regular search page does return pages that have "posted by x" (when searching for x that is :-) on them, so I don't actually have to wade through pages trying to find someone.
posted by cCranium at 1:36 PM on April 10, 2001

yeah, it's pretty easy to write this, though some people have spaces in their usernames (which would require a %20 in the string.
posted by mathowie (staff) at 1:49 PM on April 10, 2001

Remember though, there are a few duplicates here and there, so some people's profiles (like mine) are fucked up until I remove the dupes.
posted by mathowie (staff) at 10:23 PM on April 10, 2001

i've been wanting this for a long time. thanks Rob for asking and Matt for doing the work
posted by Sean Meade at 10:56 AM on April 11, 2001

Thanks Matt, this rocks.

heh, no that I think about it, a stat on the longest ramble in user profile would be amusing too.
posted by cCranium at 11:30 AM on April 11, 2001

Also, IE automagically puts the %20 in the spaces, which means I have even less thinking to do to find someone's profile. Yay!
posted by cCranium at 11:30 AM on April 11, 2001

Speaking of %20, does MeFi automatically convert spaces in links to %20s? When I posted a link the other day with a space in the anchor tag, I think it was changed. The filename in the link went from "grailmm.php#Scene 2" to "grailmm.php#Scene%202". Unfortunately, the anchor in the latter link does not seem to work.

The new username URLs are great! Thanks!
posted by Aaaugh! at 2:52 PM on April 11, 2001

« Older TimeZone Bug   |   Air your dirty laundry here? Newer »

You are not logged in, either login or create an account to post comments